Would upgrading PHP in my server affect LPCP installation?

Since lunarpanel is using it’s own PHP and Apache installations, there won’t be any issues in upgrading the PHP version in the server.